Topics

processing of maps

joerg_2712
 

Hi,

I am testing the processing of maps and topics. I will create a website
with a toc. I am using the map2WebHTMLTOC.xsl from dita13.
Topic transformation is ok, the output-directory (outputdir) is "html".
The map-file docu.xml was transformed to docu.html, but not in the directory
"html". The HTML-file was stored in the same directory as the XML source file.

The links in the toc are the same as in xml. So the prefix "html" is missing.

XML (MAP)
<map title="Doku" locktitle="yes" toc="yes">
<topicref href="p/21727.xml" title="21727" type="topic" navtitle="21727"/>
<topicref href="p/21728.xml" title="21728" type="topic" navtitle="21728"/>
<topicref href="p/21730.xml" title="21730" type="topic" navtitle="21730"/>
</map>


Created HTML:
<html><head><title>Doku</title></head><body><h1>Doku</h1>
<ul>
<li><a href="p/21727.html" class="topicref">Vakuumfüller P10 SE Typ 59521727</a></li>
<li><a href="p/21728.html" class="topicref">Vakuumfüller P10 SE Typ 59521728</a></li>
<li><a href="p/21730.html" class="topicref">Vakuumfüller P10 SE Typ 59521730</a></li>
</ul></body></html>

Could somebody help me?

Thanks and best regards

Joerg

________________________________________________
Jörg Ferlein

Ringstraße 69
73666 Baltmannsweiler

Tel. 07153 55 74 50
Fax 07153 55 74 51
E-Mail: ferlein@...

Michael Priestley
 

I'm not sure I understand. What do you want to change about the output?

Michael Priestley
mpriestl@...
Dept PRG IBM Canada phone: 416-915-8262
Toronto Information Development




ferlein@...
e To: dita-users@...
cc:
06/26/2004 05:47 Subject: [dita-users] processing of maps
AM
Please respond to
dita-users




Hi,

I am testing the processing of maps and topics. I will create a website
with a toc. I am using the map2WebHTMLTOC.xsl from dita13.
Topic transformation is ok, the output-directory (outputdir) is "html".
The map-file docu.xml was transformed to docu.html, but not in the
directory
"html". The HTML-file was stored in the same directory as the XML source
file.

The links in the toc are the same as in xml. So the prefix "html" is
missing.

XML (MAP)
<map title="Doku" locktitle="yes" toc="yes">
<topicref href="p/21727.xml" title="21727" type="topic" navtitle="21727"/>
<topicref href="p/21728.xml" title="21728" type="topic" navtitle="21728"/>
<topicref href="p/21730.xml" title="21730" type="topic" navtitle="21730"/>
</map>


Created HTML:
<html><head><title>Doku</title></head><body><h1>Doku</h1>
<ul>
<li><a href="p/21727.html" class="topicref">Vakuumfüller P10 SE Typ
59521727</a></li>
<li><a href="p/21728.html" class="topicref">Vakuumfüller P10 SE Typ
59521728</a></li>
<li><a href="p/21730.html" class="topicref">Vakuumfüller P10 SE Typ
59521730</a></li>
</ul></body></html>

Could somebody help me?

Thanks and best regards

Joerg

________________________________________________
Jörg Ferlein

Ringstraße 69
73666 Baltmannsweiler

Tel. 07153 55 74 50
Fax 07153 55 74 51
E-Mail: ferlein@...





Yahoo! Groups Links

joerg_2712
 

Hi,

I'm not sure I understand. What do you want to change about the output?
ok, another description:

I would like to change the output so that the links work in the table
of contents. ;-)

I store all the DITA-topics in a directory named "p" and the MAP-file
in the parent directory.
That is the information pool, the source.

Example:
<map title="Doku" locktitle="yes" toc="yes">
<topicref href="p/21727.xml" title="21727" type="topic" navtitle="21727"/>
...
</map>

I will create a website with a toc in the homepage in the
target-directory "html".

If I define the parameter outputdir to the value "html", then the
map2WebHTMLTOC.xsl produce this output.

My Problem: The toc-links not linked to html/p...

I repeat a part of the created html from my first mail:
<ul>
<li><a href="p/21727.html" class="topicref">P10 SE Typ 595 21727</a></li>

The ul-list with the links an the labels (title of target-topic)
were produced correctly.

However, the links don't refer to HTML/p/21727. "HTML" is missing.

I hope (despite my not so good English knowledge) that I have
described the problem understandably now.

Thanks and best regards

Joerg









--- In dita-users@..., Michael Priestley <mpriestl@c...>
wrote:




I'm not sure I understand. What do you want to change about the output?

Michael Priestley
mpriestl@c...
Dept PRG IBM Canada phone: 416-915-8262
Toronto Information Development



ferlein@i...
e To:
dita-users@...
cc:
06/26/2004 05:47 Subject:
[dita-users] processing of maps
AM
Please respond to
dita-users



Hi,

I am testing the processing of maps and topics. I will create a website
with a toc. I am using the map2WebHTMLTOC.xsl from dita13.
Topic transformation is ok, the output-directory (outputdir) is "html".
The map-file docu.xml was transformed to docu.html, but not in the
directory
"html". The HTML-file was stored in the same directory as the XML source
file.

The links in the toc are the same as in xml. So the prefix "html" is
missing.

XML (MAP)
<map title="Doku" locktitle="yes" toc="yes">
<topicref href="p/21727.xml" title="21727" type="topic"
navtitle="21727"/>
<topicref href="p/21728.xml" title="21728" type="topic"
navtitle="21728"/>
<topicref href="p/21730.xml" title="21730" type="topic"
navtitle="21730"/>
</map>


Created HTML:
<html><head><title>Doku</title></head><body><h1>Doku</h1>
<ul>
<li><a href="p/21727.html" class="topicref">Vakuumfüller P10 SE Typ
59521727</a></li>
<li><a href="p/21728.html" class="topicref">Vakuumfüller P10 SE Typ
59521728</a></li>
<li><a href="p/21730.html" class="topicref">Vakuumfüller P10 SE Typ
59521730</a></li>
</ul></body></html>

Could somebody help me?

Thanks and best regards

Joerg

________________________________________________
Jörg Ferlein

Ringstraße 69
73666 Baltmannsweiler

Tel. 07153 55 74 50
Fax 07153 55 74 51
E-Mail: ferlein@i...





Yahoo! Groups Links

Don Day <dond@...>
 

"joerg_2712" <ferlein@...> wrote on 06/30/2004 01:26:19 AM:

My Problem: The toc-links not linked to html/p...
I understand the problem now, Joerg. The maputil.xsl stylesheet which
contains that parameter only uses it to ensure that files get written to
the intended new directory. However it seems that this value is not
getting used properly for building the hrefs in the TOC. Perhaps the
toc-links should be generated within the write-html template, which knows
about this state change. The programmer for this function is on vacation
through the next two weeks, so I ask that any reader who wants to look into
this start with map2TOC.xsl and maputil.xsl and see if you can discern
where this value is being dropped during the creation of hrefs in the TOC.

Regards,
--
Don Day <dond@...>
Chair, OASIS DITA Technical Committee
IBM Lead DITA Architect
11501 Burnet Rd., MS 9037D018, Austin TX 78758
Ph. 512-838-8550 (T/L 678-8550)

"Where is the wisdom we have lost in knowledge?
Where is the knowledge we have lost in information?"
--T.S. Eliot