PDF: suppress auto-link generation when encountering URL in text? #PDF

Larry Kollar

One of our other writers pointed out that URLs appearing as content get turned into links (without extra formatting) when publishing PDF. Is there a way to turn that off? I didn't see any properties in the online docs that looked like they would help. Is this something we can do without performing major surgery on the toolkit? We're using 2.5.4 with a CCMS, if that makes a difference. Searching the archive didn't turn up anything for me.

I remember LwDITA versions <= 2.0.2 would choke when they hit URLs in MDITA content, unless wrapped in link markup. IIRC, it was a problem with a Java lib. That may be relevant. I just hope it's not something Acrobat's doing.

Thanks in advance for any help!

Huntley Eshenroder

As you fear, I believe this is a property in Acrobat. You should be able to turn it off in the Acrobat preferences and observe if it still happens.

Larry Kollar

You were correct! Acrobat's Preferences -> General tab -> uncheck "Create Links from URLs."

Personally, I like having URLs made clickable, but I can see why others might not.

Patricia Billard

I'm afraid it is an Acrobat "feature"
When the file is opened in Acrobat, Acrobat autodetects things that look like links and mailto. 
Here are a few posts about the issue.  The first one talks about links NOT working, but the answer describes how what's happening with the Adobe autodetect feature.  It talks about disabling the feature, but I think that's on a user-by-user basis, not something you can do for file generation. The feature can be enabled/disabled by selecting/deselecting the General > "Create links from URLs" option in the Preferences dialog.  (Please note that the Preferences dialog is available in Acrobat Pro, Standard, and Reader desktop apps only.)
I'm not aware of ways to disable it from source content, but one blog post I saw talked about using "hair spaces" in the content to fool the autodetection.